Did you know? – D2L Browser Support

Having issues with D2L? Did you know that in order for D2L to work to its full potential, it needs to run on a supported browser?  We recommend that if you are having issues make sure that your browser has been updated to a supported version before contacting D2L Support. Below is a list of the browsers that are supported by D2L:

Operating System Browser Version Status
Windows Internet Explorer 10 Investigation
9 Supported (recommended)
8 Maintenance
7 Unsupported
Firefox Newest Supported (recommended)
10.0 Maintenance
Chrome Newest Supported
Operating System Browser Version Status
Mac OS X Safari 5.1 Supported
5.0 Maintenance
4.0 Maintenance
Firefox Newest Supported (recommended)
10.0 Maintenance
Chrome Newest Supported

A complete list of supported browsers and portable/mobile devices is available at: D2L Platform Requirements.

If you have any additional questions or concerns, please contact UW-W D2L Support.

Leave a Reply

Your email address will not be published.